Press "Enter" to skip to content

Flutter引用其他插件报xx_plugin-Swift.h’ file not found

Last updated on 2021年3月28日

在Podfile文件里添加或打开注释

use_frameworks!

类似如下:

target 'Runner' do
  use_frameworks! # <--- add this
  ...
end

post_install do |installer|
  installer.pods_project.targets.each do |target|
    target.build_configurations.each do |config|
      config.build_settings['ENABLE_BITCODE'] = 'NO'
      config.build_settings['SWIFT_VERSION'] = '4.0' # <--- add this
    end
  end
end

因为插件是由swift构建,需要增加桥接文件

issue:https://github.com/Baseflow/flutter-google-api-availability/issues/4#issuecomment-425134594

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注

Captcha Code