composer 使用指定PHP版本安装

直接使用 composer 安装时会自动使用环境变量 php 进行版本依赖检查。

如果你有多个PHP版本,那么在部署时需要指定相应的 php 环境,如下

# 使用默认 php 环境 7.4
/usr/bin/php /usr/local/bin/composer update

# 使用 php8.2 环境
/usr/bin/php82 /usr/local/bin/composer install

以上路径对应到自己本地程序即可

Author: thinkwei

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注